East of the Sun, West of the Moon

2005/9/14

You want to remove what?

Filed under: Software — Erwin @ 2:08 pm

And here’s why I don’t let apt-get dist-upgrade run on auto-pilot but only run it every night to download the packages it thinks it needs:

The following packages will be REMOVED:
  mythmusic mythtv mythtv-backend mythtv-frontend mythtv-themes mythweather
The following packages have been kept back:
  libmyth-0.18.1 mythtv-debug
The following packages will be upgraded:
  libnspr4 mozilla-browser mythtv-common mythtv-database mythtv-doc
5 upgraded, 0 newly installed, 6 to remove and 2 not upgraded.

Right.

Update: To clarify, it works fine 90% of the time, but I’d like to have some say in it before it goes and removes the mythtv and mythtv-backend packages and would really prefer to keep the other ones installed as well. Not much point in having mythtv-common, mythtv-database, or mythtv-doc installed without those, after all. So what I do is run it as apt-get update -d dist-upgrade, so it’ll only download the *.deb files (that it thinks it needs) and the next morning or so I’ll eyeball the result (emailed to me) and decide to run apt-get update dist-upgrade or pick-and-choose what I think is actually needed.

No Comments

No comments yet.

RSS feed for comments on this post.

Sorry, the comment form is closed at this time.

Powered by WordPress